Current time: 11-28-2020, 01:05 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Webpage test user agent string missed to handle one of user agent string
03-09-2020, 04:36 PM
Post: #1
Webpage test user agent string missed to handle one of user agent string
Hi team.
we see webpagetest is not passing User agent string correctly for one of my page
https://www.ancestry.com/cs/offers/freetrial

for this page deksktop and mobile view is different .
mobile view is correct when actually renderred by real mobile device or chrome lighthouse audit .

but when simulated using wpt test , its using different user agent string.

I understand that by passing custom user agent string we can make this work (which is actually working ), but i think instead of bypassing what actual user using User agent just to get our desired results will not be right approach.

so please consider this as an defect


wrong view :
https://www.webpagetest.org/result/20030...e57ff46b1/

(user agent : Mozilla/5.0 (Linux; Android 4.4.4; Nexus 7 Build/KTU84P) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.146 Mobile Safari/537.36 PTST/200226.180231)

correct view :

https://www.webpagetest.org/result/20030...704caa75a/

(user agent : Mozilla/5.0 (Linux; Android 6.0.1; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3694.0 Mobile Safari/537.36 Chrome-Lighthouse PTST/200226.18023)
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)