WebPagetest Forums
Private instance on Windows Server 2012 R2 - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Private instance on Windows Server 2012 R2 (/showthread.php?tid=14599)



Private instance on Windows Server 2012 R2 - aanichin - 11-16-2016 08:25 AM

It took me some time but I was able to install a private instance of WPT on Windows Server 2012 R2.

Putting shortcuts in the Startup folder does not work and I had to use the Task Scheduler instead. UrlBlast and WptDriver tasks are started on user log on. This is needed in order for WPT to be able to capture screen-shots.

I also had to enable auto-login for the user account and disable a legal notice banner that is normally shown when user logs in.

Everything works fine for Google Chrome and Firefox.

If I choose IE11 for a browser I can see that UrlBlast picks up the job and then the server restarts. Very bizarre. I cannot find any information in the Event Log to tell me why this is happening.

Has anyone encountered this problem? How to fix it?

Thanks!


RE: Private instance on Windows Server 2012 R2 - pmeenan - 11-22-2016 12:35 AM

Don't use urlblaster for IE 11. URLBlaster is mostly for pre-IE9 testing and is deprecated (guess I need to clean up the docs). Add an "IE 11" to the browser list for the wptdriver location and make sure wptdriver.ini has an "IE 11" entry that points to the 32-bit version of IE 11 and it should work a lot better.