Current time: 10-25-2020, 07:30 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
First view : More than 20 secs !
06-16-2011, 03:34 PM (This post was last modified: 06-16-2011 06:16 PM by fanboss.)
Post: #1
First view : More than 20 secs !
Hello,
Just to prevent you : I have got a horrible level of English.... Just as a prevention...

The test is showing me that the first view take 23.763s to load.
That is huge... I guess... It's actually my first website so I don't know.
I still have 96/100, and I used many site analyzer as Page Speed Online and others, and all of them showed me as this site great results ! So why is it that slow for the first view...

The problem I have is that my website needs MANY images (an hundred I think) and no, i can't use sprite and CSS to avoid this big loading.
I heard of "Parallelize downloads across hostnames", but how does it work exactly, and is it really helpful for me ? I understood the point of this (the browser which load only 6 things at the same time) but I didn't understand what to do to correct it.

The other problem is this : Keep-alive Enabled --> F. I'm on a mutualized hosting, so I don't have the power to restart the server or even activate Keep-Alive. But on my host, which is infomaniak, doesn't say anything about it.

Oh and I activated a cache for the static content, but I still receive a F... Why ? (Repeat View = 1.114s).


If somebody could help me... Thank You.

Link of the results : http://www.webpagetest.org/result/110616_XZ_V8FH/
Find all posts by this user
Quote this message in a reply
06-16-2011, 10:31 PM
Post: #2
RE: First view : More than 20 secs !
Hi Fanboss,

The tested page has more than 100 files. The "Keep Alive" disabled costs you about 145 milliseconds for every one of your files.

100 files x 140 milliseconds = 14 seconds!

If your current hosting company is unable or unwilling to enable "Keep Alive" for you, consider looking for a new host for the website.

Marvin
Find all posts by this user
Quote this message in a reply
06-17-2011, 12:25 AM
Post: #3
RE: First view : More than 20 secs !
If your hosting company won't enable keep-alives and you don't want to change providers (though you really should vote with your wallet), you can use a CDN in front of your site and they can take care of it for you. CloudFlare has a free offering that might work for your site.

For the static file caching, if it is less than 30 days it will get a warning and it looks like yours are set for 7 days which is causing the issue with the check (your headers are working fine, they just aren't as long as I would normally recommend). This one isn't NEARLY as critical as the keep-alives.
Visit this user's website Find all posts by this user
Quote this message in a reply
06-18-2011, 02:43 PM
Post: #4
RE: First view : More than 20 secs !
I contacted my hosting company about the keep-alive function.

I already tried CouldFare... But I can't rename the servers, as I'm on mutualized hosting.

Ok for the cache problem, I understand, but I prefer to leave it at 7 days. Smile

Thanks for the help ! Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)