Current time: 12-07-2019, 07:32 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
304 returning in repeat view for every image
11-16-2010, 08:01 PM
Post: #1
304 returning in repeat view for every image
Hi,

I am testing the home page of my website. I have uploaded all the used images to Amazon S3 using Bucket Explorer & set Expires header for that image folder.
Waterfall model of first view giving correct model then it prompt at top that "Test is partially complete.
This page will refresh every 30 seconds until the full test is complete." Then repeat view shown after 30 second. All the images returned 304 response. But I have set expire header to all the images then they are cached in first load. Then why it return 304 error code in repeat view?

Thanks for help.
Find all posts by this user
Quote this message in a reply
11-16-2010, 10:44 PM
Post: #2
RE: 304 returning in repeat view for every image
Whats your site? or link to the test result?

cdnplanet.com: We help you select the right CDN
Visit this user's website Find all posts by this user
Quote this message in a reply
11-17-2010, 09:53 PM
Post: #3
RE: 304 returning in repeat view for every image
(11-16-2010 08:01 PM)neelamsharma Wrote:  Hi,

I am testing the home page of my website. I have uploaded all the used images to Amazon S3 using Bucket Explorer & set Expires header for that image folder.
Waterfall model of first view giving correct model then it prompt at top that "Test is partially complete.
This page will refresh every 30 seconds until the full test is complete." Then repeat view shown after 30 second. All the images returned 304 response. But I have set expire header to all the images then they are cached in first load. Then why it return 304 error code in repeat view?

Thanks for help.


Hi, my testing result - http://www.webpagetest.org/result/101111...ls/cached/
My query is that though all the images are downloaded once in first preview to browser using GET request, then why repeat view responding 304 error. i also have set "Expires" (31 Dec, 2049) headers on images. Why 304 there?

Thanks
Find all posts by this user
Quote this message in a reply
11-18-2010, 02:11 AM
Post: #4
RE: 304 returning in repeat view for every image
(11-17-2010 09:53 PM)neelamsharma Wrote:  Hi, my testing result - http://www.webpagetest.org/result/101111...ls/cached/
My query is that though all the images are downloaded once in first preview to browser using GET request, then why repeat view responding 304 error. i also have set "Expires" (31 Dec, 2049) headers on images. Why 304 there?

Thanks

Code:
Expires: Fri, Dec 31 2049 23:59:59 GMT

That maybe the problem?
Maybe IE is getting confused with so far future expires.. never seen a site using 40 years for it. try setting a date in 2011 or 2012.

The specs call for no more than 1 year.

Quote:To mark a response as "never expires," an origin server sends an Expires date approximately one year from the time the response is sent. HTTP/1.1 servers SHOULD NOT send Expires dates more than one year in the future.

cdnplanet.com: We help you select the right CDN
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)