Current time: 02-27-2021, 08:25 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
how to Test Site with Cloudflare DNS and Direct from Server
01-16-2021, 05:31 AM
Post: #1
how to Test Site with Cloudflare DNS and Direct from Server
i want to review why my site is giving high FFTB after using cloudflare. can i test my site direct to server without removing Cloudflare.

thanks for your help.
Find all posts by this user
Quote this message in a reply
01-27-2021, 07:17 AM
Post: #2
RE: how to Test Site with Cloudflare DNS and Direct from Server
You can add this snippet to the scripting tab to first set the DNS to the origin server for the domain, then to navigate and return a test result.

setDns example.com 0.0.0.0
navigate https://example.com
Visit this user's website Find all posts by this user
Quote this message in a reply
02-15-2021, 03:52 PM
Post: #3
RE: how to Test Site with Cloudflare DNS and Direct from Server
@huma1985 I recently saw something similar on my site. A few pointers you may find helpful:

  1. By default CloudFlare does NOT cache text/html. If you inspect the request for your html page you will see an http header like "cf-cache-status: DYNAMIC". Dynamic means it will never cache this page (vs HIT or MISS for cacheable resources).
  2. This means your cloudflare requests are always being proxied to origin, and so the TTFB will increase the further a test location you choose in WebPageTest from your origin. It will be roughly linear increase in TTFB as to distance from origin.
  3. If you add a "page rule" in cloudflare to "Cache Everything" (including text/html) then it will cache your html pages and you will see http header "cf-cache-status" as HIT or MISS. Certainly your 2nd or subsequent test run should be considerably faster with TTFB <=100ms for a warmed up CloudFlare edge location.

But also I noticed that in my case, my nginx was set to provide cache headers by file extension. So while working for 90% of everything was not setting cache headers on extensionless URLs ending in "/". So I changed my nginx config to apply cache headers by mime-type for text/html. That fixed the extenionless url cache headers.

If my post helps you, click the little "user +" icon on the lower left to give me a rep!
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)