Current time: 12-09-2019, 06:40 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Link to showslow result not correct
08-01-2011, 08:24 AM
Post: #1
Link to showslow result not correct
On the webpagetest test result screen, there is a link called "See in ShowSlow" which points to: http://hostname/showslow/beacon/yslow/details/?url=http%3A%2F%2Fwhatever.com%2F#webpagetest

this URL should not point to "../showslow/beacon/yslow/details/?..." but to "../showslow/details?..." (also notice removal of the forward slash in front of the question mark)

To correct this, add a parameter to settings.ini (I called it "showslowbase") and put in the path to the showslow base location. For example:

;showslow beacon
showslow=http://g1lwltreport.dc1.corp.gd:8080/showslow/beacon/yslow

;showslow base
showslowbase=http://g1lwltreport.dc1.corp.gd:8080/showslow

Then, in result.inc, change line 102:

from:

echo '<br><a href="'.$settings['showslow'].'/details/?url='.urlencode(FixUrlSlash($url)).'#webpagetest' . '">See in ShowSlow</a>';

to:

echo '<br><a href="'.$settings['showslowbase'].'/details?url='.urlencode(FixUrlSlash($url)).'#webpagetest' . '">See in ShowSlow</a>';
Find all posts by this user
Quote this message in a reply
08-02-2011, 09:51 AM
Post: #2
RE: Link to showslow result not correct
Sorry, moved because WPT Monitor is actually a different project.

You may need an updated show slow install. You don't point it to the yslow beacon - the latest versions of show slow have native support for a custom beacon from WebPagetest. You should just use the show slow base for the show slow definition and the relative url's will be figured out automatically.

Thanks,

-Pat
Visit this user's website Find all posts by this user
Quote this message in a reply
08-04-2011, 07:17 AM
Post: #3
RE: Link to showslow result not correct
Hey Pat,

Let me thanks you first of all for all your great work! I love WPT, especially in combination with ShowSlow!

I guess it was just confusion on my part then. I must have gotten used to pointing things at the yslow beacon such that anytime i see the word beacon, i point it at yslow ... ;-)

however ... after i changed settings.ini to point at showslow base, i started getting 500 errors in response to the POST to the webpagetest beacon. This looks a lot like the issue described here: http://groups.google.com/group/showslow/...84eaa2b89f) ...

if you have any insight into this issue, let me know ... i will post this to the showslow group too.
Find all posts by this user
Quote this message in a reply
08-04-2011, 10:42 AM
Post: #4
RE: Link to showslow result not correct
Just as a sanity check, are you running a 1.1+ build of show slow? Earlier builds didn't have support for it.
Visit this user's website Find all posts by this user
Quote this message in a reply
08-04-2011, 10:52 AM
Post: #5
RE: Link to showslow result not correct
yep, 1.1.2 to be exact ...

(08-04-2011 10:42 AM)pmeenan Wrote:  Just as a sanity check, are you running a 1.1+ build of show slow? Earlier builds didn't have support for it.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)