WebPagetest Forums
Compress Transfer is N/A - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Compress Transfer is N/A (/showthread.php?tid=14462)



Compress Transfer is N/A - DenverDev - 08-17-2016 07:38 AM

Test results:
https://www.webpagetest.org/result/160816_A2_2E3Q/

The hosting company said that gzip is verified and working. That being the case, why would the results show N/A?

I'm using nginx. Is there a setting that can affect it? Is WebPageTest.org just not recognizing it?

Thanks for the help.


RE: Compress Transfer is N/A - pmeenan - 08-17-2016 07:41 AM

Looks like a WebPageTest bug where it isn't detecting the resources as being text resources (the html, css and js). Looking at it manually they all look to be compressed (cloudflare takes care of it for you regardless of your nginx settings).

I'll take a look to see if I can track down the bug in the morning.


RE: Compress Transfer is N/A - DenverDev - 08-17-2016 10:07 AM

Thank you sir! I want this to be perfect, and I'm getting there.

Thanks for the help.


RE: Compress Transfer is N/A - pmeenan - 08-18-2016 02:02 AM

Fixed now, thanks for finding that: https://www.webpagetest.org/result/160817_XZ_2NFS/

Looks like you have a font that isn't being compressed. You should be able to configure cloudflare to include .ttf files for gzip:

FAILED - (81.0 KB, compressed = 34.8 KB - savings of 46.2 KB) - https://royalrestrooms.com/wp-content/themes/Divi/core/admin/fonts/modules.ttf


RE: Compress Transfer is N/A - pmeenan - 08-18-2016 02:05 AM

Looks like cloudflare will compress fonts as long as they have a reasonable mime type (like application/ttf or font/ttf). Looks like you are serving them as content-type: application/octet-stream

If you change your nginx config to know that .ttf should be font/ttf it should start working.


RE: Compress Transfer is N/A - DenverDev - 08-18-2016 03:58 AM

On it. Thanks for the advice Patrick.