WebPagetest Forums
Complete newbie needs help! - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Complete newbie needs help! (/showthread.php?tid=13329)



Complete newbie needs help! - Shane in the UK - 10-28-2014 01:03 AM

I've created a fairly basic web site for our taxi business using Wix. We've been very unhappy with the slow upload speed (25-30 secs), but I found WPT.org and have run a test on the site to see if there is any obvious sign what is causing this.

The results can be found here: http://www.webpagetest.org/result/141027_MT_M8S/

I am a complete novice at this, but even I realise that on the Performance Review page, two red crosses under the 'CDN Detected' column, another red cross under 'GZip', and two warning triangles under 'Cache Static' is 'not good'.

Can someone explain what this means and what, if anything, I can do to improve this?

Thanks in advance...


RE: Complete newbie needs help! - josephscott - 10-29-2014 03:22 AM

Loading all of those separate JavaScript and JSON files is brutal.


RE: Complete newbie needs help! - pmeenan - 10-29-2014 11:38 PM

I'm thinking you should probably look at a different platform. You kind of get what you pay for with the free and cheap shared hosting and it doesn't look like the Wix template is particularly conducive to a fast site (even if the server performed well which it doesn't).


RE: Complete newbie needs help! - Shane in the UK - 10-31-2014 02:24 AM

(10-29-2014 11:38 PM)pmeenan Wrote:  I'm thinking you should probably look at a different platform. You kind of get what you pay for with the free and cheap shared hosting and it doesn't look like the Wix template is particularly conducive to a fast site (even if the server performed well which it doesn't).

Patrick, thanks for your view. I was beginning to think it may be the platform rather than the content (?). Question is, after all the hours put in to getting the site to this stage, do I have to start from scratch on another platform and, if so, which one?
The other thing that bothers me about the report is the First Byte Time - 1656ms against a target of 444ms maximum (which is generous). Based on your knowledge, do you think this is anything to do with where the domain name is hosted? It shows up as Austin, Tx - which I'm assuming is just a domain server of some sort?
Would appreciate your opinion.
Regards
Shane


RE: Complete newbie needs help! - pmeenan - 11-04-2014 02:30 AM

The 1.6s doesn't have anything to do with the geography. That's almost all time spent on the server itself. I assume that a lot of the script is actually coming from the platform as well and not something that you did in adding the content so the core issues all go back to the platform (both the slow server response times and the slow page performance once the page has been delivered to the browser).

As to which platform, I'm probably not a good one to ask. My vote would be for a VM on one of the compute platforms (Amazon, Google or Microsoft) where you have full control over the stack and can choose to re-size the hardware as needed. Most sites would be able to run on the lowest tier of VM and still be orders of magnitude faster than the cheap shared hosting (and would be < $10/month) but it requires someone to do the actual work in setting up and maintaining the server.

If you build on top of something like wordpress instead of wix then at least you have a lot of hosting options available (both managed and on your own). Something like WPEngine might be a good choice but it kind of depends on what scale you're looking for and what your budget is for hosting.